]> www.wagner.pp.ru Git - oss/fgis.git/blobdiff - tcl/Makefile.am
uninstall targets added
[oss/fgis.git] / tcl / Makefile.am
index 41a33d8c0430d4dfee421ceb5dd722d140825f2e..daae713a503834c51c8b5ca10b24e6708ecb6b62 100644 (file)
@@ -22,7 +22,7 @@
 bin_SCRIPTS = hypermap mapview
 SCRIPT_LIST = admin.layer balloonhelp.tcl calculator.tcl combobox.tcl console.tcl draw.tcl getopt.tcl help.tcl hierarchy.tcl html_library.tcl layer.tcl legend.tcl lesras.lay objects.tcl planchet.tcl progressbar.tcl tabnotebook.tcl tclIndex toolbar.tcl ventry.tcl viewer.tcl widget.tcl
 
-SCRIPTDIR=$(TCL_PACKAGE_PATH)/fgis
+EXTRA_DIST = $(bin_SCRIPTS) $(SCRIPT_LIST)
 
 install: all install-binaries install-libraries
 
@@ -35,14 +35,22 @@ install-binaries:
        done
 
 install-libraries:
-# install standalone scripts
-       $(mkinstalldirs) $(SCRIPTDIR)/tcl
+       $(mkinstalldirs) $(FGIS_SCRIPTDIR)
        -for i in $(SCRIPT_LIST) ; do \
          if [ -f $$i ] ; then \
-           $(INSTALL_PROGRAM) $$i $(SCRIPTDIR)/tcl/$$i ; \
+           $(INSTALL_PROGRAM) -m 644 $$i $(FGIS_SCRIPTDIR)/$$i ; \
          else true; fi ; \
        done
+       $(mkinstalldirs) $(TCL_PACKAGE_PATH)/fgis
        if [ -f pkgIndex.tcl  ] ; then \
-           $(INSTALL_PROGRAM) pkgIndex.tcl $(SCRIPTDIR)/pkgIndex.tcl ; \
+           $(INSTALL_PROGRAM) -m 644 pkgIndex.tcl $(TCL_PACKAGE_PATH)/fgis/pkgIndex.tcl ; \
        else true; fi
 
+uninstall:
+       -for i in $(bin_SCRIPTS) ; do \
+         rm -f $(bindir)/$$i ; \
+       done
+       -for i in $(SCRIPT_LIST) ; do \
+         rm -f $(FGIS_SCRIPTDIR)/$$i ; \
+       done
+       -rm -f $(TCL_PACKAGE_PATH)/fgis/pkgIndex.tcl