]> www.wagner.pp.ru Git - oss/fgis.git/blobdiff - tcl/Makefile.am
uninstall targets added
[oss/fgis.git] / tcl / Makefile.am
index 816f4094daa7e7e51023532418d7723a33e9c860..daae713a503834c51c8b5ca10b24e6708ecb6b62 100644 (file)
@@ -22,6 +22,8 @@
 bin_SCRIPTS = hypermap mapview
 SCRIPT_LIST = admin.layer balloonhelp.tcl calculator.tcl combobox.tcl console.tcl draw.tcl getopt.tcl help.tcl hierarchy.tcl html_library.tcl layer.tcl legend.tcl lesras.lay objects.tcl planchet.tcl progressbar.tcl tabnotebook.tcl tclIndex toolbar.tcl ventry.tcl viewer.tcl widget.tcl
 
+EXTRA_DIST = $(bin_SCRIPTS) $(SCRIPT_LIST)
+
 install: all install-binaries install-libraries
 
 install-binaries:
@@ -44,3 +46,11 @@ install-libraries:
            $(INSTALL_PROGRAM) -m 644 pkgIndex.tcl $(TCL_PACKAGE_PATH)/fgis/pkgIndex.tcl ; \
        else true; fi
 
+uninstall:
+       -for i in $(bin_SCRIPTS) ; do \
+         rm -f $(bindir)/$$i ; \
+       done
+       -for i in $(SCRIPT_LIST) ; do \
+         rm -f $(FGIS_SCRIPTDIR)/$$i ; \
+       done
+       -rm -f $(TCL_PACKAGE_PATH)/fgis/pkgIndex.tcl