]> www.wagner.pp.ru Git - oss/fgis.git/blobdiff - tcl/Makefile.am
*** empty log message ***
[oss/fgis.git] / tcl / Makefile.am
index 41a33d8c0430d4dfee421ceb5dd722d140825f2e..2c1a7302f18d489393d0260c5b6a002e5c93453f 100644 (file)
@@ -22,8 +22,6 @@
 bin_SCRIPTS = hypermap mapview
 SCRIPT_LIST = admin.layer balloonhelp.tcl calculator.tcl combobox.tcl console.tcl draw.tcl getopt.tcl help.tcl hierarchy.tcl html_library.tcl layer.tcl legend.tcl lesras.lay objects.tcl planchet.tcl progressbar.tcl tabnotebook.tcl tclIndex toolbar.tcl ventry.tcl viewer.tcl widget.tcl
 
-SCRIPTDIR=$(TCL_PACKAGE_PATH)/fgis
-
 install: all install-binaries install-libraries
 
 install-binaries:
@@ -35,14 +33,14 @@ install-binaries:
        done
 
 install-libraries:
-# install standalone scripts
-       $(mkinstalldirs) $(SCRIPTDIR)/tcl
+       $(mkinstalldirs) $(FGIS_SCRIPTS)
        -for i in $(SCRIPT_LIST) ; do \
          if [ -f $$i ] ; then \
-           $(INSTALL_PROGRAM) $$i $(SCRIPTDIR)/tcl/$$i ; \
+           $(INSTALL_PROGRAM) -m 644 $$i $(FGIS_SCRIPTS)/$$i ; \
          else true; fi ; \
        done
+       $(mkinstalldirs) $(TCL_PACKAGE_PATH)/fgis
        if [ -f pkgIndex.tcl  ] ; then \
-           $(INSTALL_PROGRAM) pkgIndex.tcl $(SCRIPTDIR)/pkgIndex.tcl ; \
+           $(INSTALL_PROGRAM) -m 644 pkgIndex.tcl $(TCL_PACKAGE_PATH)/fgis/pkgIndex.tcl ; \
        else true; fi