]> www.wagner.pp.ru Git - oss/fgis.git/blobdiff - dll/Makefile.am
The first attempt to automate building process
[oss/fgis.git] / dll / Makefile.am
diff --git a/dll/Makefile.am b/dll/Makefile.am
new file mode 100644 (file)
index 0000000..938639a
--- /dev/null
@@ -0,0 +1,29 @@
+## $ID: $
+##
+## Copyright (C) 2002, Andrey Kiselev <dron@remotesensing.org>
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+## USA.
+
+## Process this file with automake to produce Makefile.in.
+
+fgis_la_LDFLAGS = -module -avoid-version
+lib_LTLIBRARIES = fgis.la
+fgis_la_SOURCES =  fgisInit.c fgisMisc.c fgisPalette.c fgisRaster.c fgisPlanchet.c fgisEppCalc.c fgisEppDraw.c fgisVector.c fgisPatterns.c fgisProjection.c fgis.h fgisInt.h
+
+FGIS_HOME = $(sysconfdir)
+INCLUDES = $(TCL_INCLUDE) -I$(top_srcdir)/include
+DEFS = @DEFS@
+